Register For DVDFab Member >>

Go Back   DVDFab Forum > Software Support (English) > DVDFab Video Converter

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-17-2017, 12:27 AM
kevinfritz kevinfritz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 41
Default 10.0.4.2 Video Converter twice as slow as 10.0.3.9

I convert a lot of PAL MP4 videos to NTSC so that I get smooth playback on my Roku 4 and NTSC TV.

I had been using version 10.0.3.9 for this and like the earlier versions, I am using software decoding and encoding only because there are otherwise voice sync issues. I've seen others complain about this. I found that the software decoder and encoder worked fine and created good great quality NTSC MP4s with it set to High quality, 2-pass encoding. The encoding speed for both passes would show between 65 and 80 frames per second, usually with the higher speeds at the beginning of the encoding.

I never installed 10.0.4.0 and went right to 10.0.4.1 from 10.0.3.9 and was disappointed to see that the software encoding was now running at HALF speed or slower! I re-installed 10.0.3.9 and got back to the original speeds. I just installed 10.0.4.2 and found that it has the same slow encoding issues that 10.0.4.1 had. Did something change to the algorithm or the x264 engine that drives the encoding? If so, PLEASE go back to the version used in 10.0.3.9 so that I can get back to acceptable encoding speeds while getting the future bug fixes.

Has anyone else noticed this encoding slowdown?

I'm running DVDFab on Windows 10 on an Intel Core i5 processor. Encoding a 2 hour 1280x720 MP4 from 25 fps to 29.97 fps takes about 1.5 hours total for both passes with 10.0.3.9, but closer to 4 hours with the newer versions, with NO increase in quality....

Thanks,
kevinfritz
Reply With Quote
  #2  
Old 06-18-2017, 05:28 PM
signals's Avatar
signals signals is online now
Administrator - 守夜人
 
Join Date: Sep 2009
Posts: 11,445
Default

I am not aware of any changes between those versions that would cause the symptoms you report, but there is another thread that reports a problem with 2-pass encoding. The developers will need to take a look and see if they can duplicate your problem. In the meantime, please attach a DVDFab internal log session from one of these slow conversions to a new post. Instructions for this are linked in my sig, below.

You might also try turning off 2-pass and setting the bitrate higher using the slider until the bits per pixel (B/P) reads 0.20 or higher. Unless you have a TV with a tube-type picture display, the PAL files should display with no problem. They might look better with the frame rate set to 23.97 fps as well. Try it if you have not.
Reply With Quote
  #3  
Old 06-18-2017, 06:20 PM
kevinfritz kevinfritz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 41
Default

Quote:
Originally Posted by signals View Post
I am not aware of any changes between those versions that would cause the symptoms you report, but there is another thread that reports a problem with 2-pass encoding. The developers will need to take a look and see if they can duplicate your problem. In the meantime, please attach a DVDFab internal log session from one of these slow conversions to a new post. Instructions for this are linked in my sig, below.

You might also try turning off 2-pass and setting the bitrate higher using the slider until the bits per pixel (B/P) reads 0.20 or higher. Unless you have a TV with a tube-type picture display, the PAL files should display with no problem. They might look better with the frame rate set to 23.97 fps as well. Try it if you have not.
Another user messaged me that it could be related to the "improved conversion engine" that was previously introduced, which caused him speed problems converting 3D files. He had to go back to version 10.0.2.2 to regain the speed, and then the newer versions when he needs to rip a new disc. He noted that the improved conversion engine was supposed to speed up ripping of protected blurays, but may have introduced these issues. Not sure this would have just cropped up for me on 2D videos, but it is consistent. I'll have to re-install version 10.0.4.2 to create one of those logs....could be a few days since I need to dedicate 4 hours or so.

PAL files create jerky movement on my NTSC Sony Bravia TV, though it is probably the Roku 4 that is playing it back that way by doing a PAL to NTSC conversion "on the fly." The Sony TV would not even play back PAL videos if PAL videos are introduced directly. Since I use my Roku 4 as my default media player, I need to convert to NTSC to get smooth playback. However, I also needed to make the conversion for my Western Digital TV media player, as PAL videos from there are jerky also. 29.97 seems to work better than 23.97 fps for both players...

2-Pass and the high quality bit per pixel rate are the best combination of high quality and smaller files. I would hate to sacrifice size to get acceptable quality. Hopefully the issue can be found and fixed to avoid that compromise.

Thanks for the reply.
Reply With Quote
  #4  
Old 06-18-2017, 09:19 PM
kevinfritz kevinfritz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 41
Default

Here's a thought: could it be the following change that was introduced in 10.0.4.1 beta?

"New: Added the 10bit support to several MKV and MP4 profiles in the Ripper and Converter modules."

I'm not using 10-bit profiles for my MP4s, but did the base engine change to accommodate the 10-bit algorithm, and perhaps slow down the regular (8-bit?) MP4 conversion speed? Just a possibility...
Reply With Quote
  #5  
Old 06-18-2017, 09:26 PM
90312's Avatar
90312 90312 is offline
Moderator
 
Join Date: Sep 2009
Location: Missouri
Posts: 6,072
Default

What are converting from and to? I'll see if I can reproduce it so far I can't.
__________________
How to post the internal log


Things should be made as simple as possible, but no simpler.
Albert Einstein
Reply With Quote
  #6  
Old 06-19-2017, 04:17 AM
kevinfritz kevinfritz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 41
Default

Quote:
Originally Posted by 90312 View Post
What are converting from and to? I'll see if I can reproduce it so far I can't.
Hi. I'm converting 1280x720 25 fps MP4 files to 1280x720 29.97 fps MP4 files. The audio is already AAC, so I set video converter to copy audio, and for video I change the fps setting and choose high quality, two-pass encoding. Codecs are set to software for both decoding and encoding. For comparison I would think any resolution should work, as long as you are changing the frames per second. Higher resolutions will obviously take longer.

I will attempt to create a log with the old version and another with the new version, with the same settings and video input.
Reply With Quote
  #7  
Old 06-25-2017, 08:14 PM
kevinfritz kevinfritz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 41
Default

OK, I've finally had time to do a comparison, this time with the newly release 10.0.4.3 and 10.0.3.9. I started with a fresh log file, did the conversion with 10.0.4.3 and then re-installed 10.0.3.9 and re-ran the conversion of the exact same file with the exact same options. There is still a huge difference, but this time the new version is not more than twice as slow as 10.0.3.9.

Summary:

10.0.3.9 = 1 hour 37 minutes conversion time

10.0.4.3 - 2 hours 43 minutes conversion time

Any ideas why the new versions are so much slower?

Thanks,
kevinfritz
Attached Files
File Type: log dvdfab_internal.log (18.8 KB, 2 views)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump