DVDFab Forum - MKV Green Subtitles

Announcement

Collapse
No announcement yet.

MKV Green Subtitles

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ltrain69
    started a topic MKV Green Subtitles

    MKV Green Subtitles

    Anyone seeing green-colored subtitles in the MKV output file when selecting 'Remux to VobSub' when the source is colored white?
    Ripping to MKV selecting 'Remux to PGS' is the same as source (good).
    Ripping to MP4 with Remux is the same as source (good).
    I am using version 10.0.4.0. This never happened in pre-10.x versions.
    Enabling or disabling Lightning-Shrink gives the same results.
    I already tried several BDs and see the same results.
    Can we get this fixed in the next update? Thanks.

  • cholla
    replied
    This won't help with this problem .
    I used to sometimes get green subs when working with a DVD rip.
    Editing after the rip was the "cause".
    Somewhere the color code for the subtitles in the .IFO file would change .
    I used an old software called IFOEdit to correct this by changing the subtitles back to the original color with it.

    I suspect it is something similar happening in the .MKV &/or .MP4 files.
    It is a color change in the code that is telling the subtitles to be green.
    The developers of DVDFab need to figure out why this happens.
    Then correct so DVD Ripper & DVDFab Converter have code that keeps the subtitles the original color .
    Maybe even allow a color selection or even other options like transparency.

    Leave a comment:


  • FabioD
    replied
    FWIW, I already had this problem years ago. Tried now and still have this problem.
    I hate to say but there are several problems with DVDFab which make it almost impossible to properly rip my DVDs.
    1. Disney DVDs always have hickups when ripping to most formats. It was a problem a couple years ago, and it is still a problem today (and the hickups are always at the same spots - so it's related to Disney's copy protection. There is however a workaround (which then makes it weird that direct rip to MP4 has the problem). I can first rip to MKV Passthrough, and then convert that with DVDFab Convertor to the MP4, and the hickups are gone.
    2. But then comes the next problem: I can hardly get the subs right. Am now trying with The LEGO Movie with forced Dutch subs. The MKV is fine (both with Remux and IDX/SUB). When converting the MKV with Remuxed Subs, with subs rendered to video, the subs occur at the wrong times (one sub stayed there throughout an entire chapter). When converting with subs remuxed, I get the green subs as mentioned in this thread. Converting from the MKV with IDX/SUB is even no option at all as I can't even select these subs and would have an MP4 without subs.

    Leave a comment:


  • signals
    replied
    Nothing at the moment, sorry.

    Leave a comment:


  • virtual_francky
    replied
    Hi, any news about this problem, I still have green sub with Blu Ray Rip only, no problem with DVD Rip.

    Franck

    Leave a comment:


  • ltrain69
    replied
    Thank you.

    Leave a comment:


  • signals
    replied
    Hi ltrain
    It is a known issue for your settings. They are already working on it.

    Leave a comment:


  • ltrain69
    replied
    I tested the same file on MPC-HC, VLC, and DVDFab Media Player 3.
    All players showing the green subtitles.

    Leave a comment:


  • signals
    replied
    Well, that's a new one on me. Will pass along to the devs. What are you using to play this back?

    Leave a comment:


  • ltrain69
    replied
    From disc directly.
    Attached Files

    Leave a comment:


  • 3dman
    replied
    Try it from the store brought disk.

    Leave a comment:


  • ltrain69
    replied
    Attached is the log file.
    Attached Files

    Leave a comment:


  • signals
    replied
    If you can locate the DVDFab internal log session from one of the green ones, please attach it to a post. I have never experienced what you describe but I generally use Direct Render for translation subs and don't ever put the full dialog subs in.

    Leave a comment:

Working...
X