Announcement

Collapse
No announcement yet.

video artefact in the h264 software decoder.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • video artefact in the h264 software decoder.

    I have a mp4 file that generates blocky artefacts either in the internal preview decoder or in the transcode when using the h264 software decoder.
    Click image for larger version

Name:	videoartefact.jpg
Views:	1
Size:	48.3 KB
ID:	320397
    You can see the artefact around the orange line on the left window.

    I tried using the DXVA decoder for h264, it then cause both the video and audio streams to be copied regardless of the requested transcode. The log has the following error : 0m 00.73s: --- connect filter failed(module_vdecode_gpu query_failed Module_FabDecoder init_format) ---

  • #2
    You should always post the whole log file we don't know what settings you used to make the mp4.You can always set the settings in advanced settings to a higher bit rate try using high quality.
    Click here to learn how to post log files

    Comment


    • #3
      The Log for the encoding with the artefact
      Code:
       0m 00.03s: Init Public log: enabled.
       0m 00.03s: Init Private log: finish.
       0m 00.03s: App info: 2017-3-17
       0m 00.04s: App info: 10.0.2.9 10029 Official
       0m 00.22s: Init CrashReportSettings: enabled.
       0m 00.22s: Init DVDInfo_Log: enabled.
       0m 00.22s: app args: count 1,arg 0:C:\Program Files (x86)\DVDFab 10\DVDFab.exe,
       0m 00.22s: Init Qt_Log: disabled.
       0m 00.48s: Profile Manager :: Begin Load Profile 
       0m 00.49s: SUCCEED: IServerService WebServer Init succeed.
       0m 00.49s: SUCCEED: IServerService MediaLibrary Init succeed.
       0m 00.78s: Qt Translator file load success 
       0m 00.78s: App info: client type 22.
       0m 00.80s: MobilePlay load: preload successful.
       0m 00.88s: MobilePlay load: Load successful.
       0m 00.89s: set code page: .0
       0m 00.89s: Init process: Transfer settings successful.
       0m 00.89s: info: check logpath= D:/Users/Fred/Documents/DVDFab10/Log/
       0m 01.29s: info: _check_gpu is running ...
       0m 01.68s: info: check_gpu run successful 
       0m 01.68s: info: recommand= 0, Shrink support= 0, enable= 0, cuda_cap= 0 , cpu_count= 8
       0m 01.68s: GPU check: GPUAccelerate-0X7
       0m 01.68s: GPU check: GPUAccelerate setting-0X0, 0X0
       0m 01.68s: GPU check: CUDA cap-0X0
       0m 01.68s: GPU check: Support coreavc decode-0
       0m 01.68s: GPU check: Lighting shrink status-0, 0
       0m 01.68s: GPU check: Graphics info 1: NVIDIA GeForce GT 520M : 21.21.13.7892 : 2.1
       0m 01.69s: Init process: Load config successful.
       0m 01.69s: Init process: Windows os type is 64bit System Windows 10 Build 15063.
       0m 01.69s: Init process: command line in is 
       0m 01.94s: Reg check: Parse string: ( 61:8260762964 )( 50:8260762964 )( 2:8260762964 )( 20:8260762964 )( 1:0 )( OV:10029 )( BV:10026 )( S:8bce0da41976155fa3ebdc10282413d2 )
       0m 01.95s: Reg check: Option check status-Local
       0m 01.95s: Reg check: ( HD Decrypter:1:0 )-( DVD to DVD (Gold):0:0 )-( DVD to DVD:1:1 )-( DVD to Mobile:1:0 )-( Blu-ray to Blu-ray:1:1 )-( Blu-ray to Mobile:1:0 )-( File to Mobile:1:1 )-( Blu-ray to DVD:1:0 )-( DVD to Blu-ray:1:0 )-( File to DVD:1:1 )-( File to Blu-ray:1:0 )-( File Mover:1:0 )-( Blu-ray to 3D:1:0 )-( 2D to 3D:1:0 )-( Blu-ray Decrypt:1:0 )-( DVD Decrypt:1:0 )-( CinaviaRemoval HD:1:0 )-( DVD Cinavia Removal:1:0 )-( Blu-ray Cinavia Removal:1:0 )-
       0m 01.95s: App info: language type ENU.
       0m 01.95s: App info: Install path C:/Program Files (x86)/DVDFab 10/ 
       0m 01.95s: Init process: Set account info to DriveX.
       0m 01.95s: Export Blu-ray source information report: enabled
       0m 01.95s: Init process: Init GPU settings successful.
       0m 01.96s: connect plugin info: start.
       0m 01.99s: Reg check: Times of cinavia connecting error is: 0
       0m 01.99s: Reg check: Start get sys number.
       0m 01.99s: Reg check: Serial number is: f0-bf-97-57-c9-4f:b4-b6-76-d5-a3-b2:00-50-56-c0-00-01
       0m 01.99s: Reg check: Connect type is: 0
       0m 02.19s: Reg check: Times of connecting error is: 0
       0m 02.19s: Reg check: Parse string: ( S:a061ebebf0d1a99703c7ff9f546c4f01
       0m 02.20s: Reg check: Option check status-NewWork
       0m 02.26s: connect plugin info: 1:1
       0m 02.27s: Profile Manager :: End Load Profile 
       0m 07.24s: Init preview: Begin init preview play engine.
       0m 07.24s: Init preview: Begin init preview play engine(Internal).
       0m 09.99s: Init preview: Init internal engine successful.
       0m 10.20s: Burn engine: start init.
       0m 10.20s: Burn engine: set log folder.
       0m 10.20s: DVD: init read settings.
       0m 10.20s: DVD: init write settings.
       0m 10.38s: BD: init read settings.
       0m 10.38s: BD: init write settings.
       0m 10.38s: bd set region A
       0m 10.38s: Burn engine: config engine type-0 begin.
       0m 10.38s: Burn engine: config engine type-0 end.
       0m 10.38s: Burn engine: writer count 1.
       0m 10.38s: Burn engine: 0- H:\ [ASUS SBC-06D2X-U D201 (Usb)].
       0m 10.39s: Burn engine: end init.
       0m 11.89s: Init process: Init setting page successful.
       0m 11.90s: QtLog Mode = false 
       0m 13.08s: Start show MainUI.
       0m 13.08s: dpi scale: x scale 1.500000
       0m 13.08s: dpi scale: y scale 1.500000
       0m 13.09s: UI manager: switch to Convert mode.
       0m 13.99s: Init process: init main ui successful.
       0m 14.02s: Init process: show main ui successful.
       0m 14.02s: DriveX msg: Init driveX H with I/O mode: 0
       0m 14.05s: scene data: delete file D:/Users/Fred/Documents/DVDFab10/SceneData/d33265a0-6b06-4d77-b3b6-74cc17577b9c.SceneData.xml result=0
       0m 14.06s: scene data: delete dir D:/Users/Fred/Documents/DVDFab10/SceneData/d33265a0-6b06-4d77-b3b6-74cc17577b9c result=1
       0m 14.06s: Cinavia Version : 1.242.2.23
       0m 14.38s: opening drive H
       0m 14.39s: opened i/o
       0m 14.39s: Source manager: open source flag:1,0,1,1,1
       0m 14.40s: Source manager: open source flag:1,0,1,1,1
       0m 30.34s: Source manager: select video files for open.
       0m 30.36s: Source manager: add source id 0.
       0m 30.39s: info, try to open file D:/Users/public/DVDFab/The Flash (2014) - S2E08A - Legends of Today (part 1)/The Flash (2014) - S2E08A - Legends of Today (part 1)-1_2512_2582.m4v
       0m 30.61s: info: open successed, iformat = QuickTime / MOV
       0m 30.70s: Source manager: open successful.
       0m 30.94s: Work manager: create convert work 0 with source 0 and uiinfo 0.
       0m 30.94s: ========WorkAttr::SetSource=======
       0m 30.94s: Source Video Size Original: 1920 x 1080 
       0m 30.94s: Source Video Size Display: 1920 x 1080 
       0m 30.94s: Source Video FPS: 24000 / 1001 
       0m 30.94s: Source Video Bitrate: 1200 
       0m 30.94s: Source Audio Bitrate: 1536000 
       0m 30.94s: Source Audio Channels: 6 
       0m 30.94s: Source Audio Volume: 100 
       0m 30.94s: Work Profile: MP4 
       0m 31.39s: Source manager: open source flag:1,0,1,1,1
       0m 43.73s: UILog: OnMsgToolbar_Start
       0m 43.73s: UILog: Msg Start: ready start
       0m 43.75s: UILog: Msg Start: start test run work
       0m 43.75s: UILog: Msg Start: run work
       0m 43.75s: UILog: Run current Work.
       0m 43.75s: UILog: Begin work copy or converter.
       0m 43.75s: Start check Video Converter register status.
       0m 43.75s: End check Video Converter register status: Enable
       0m 43.76s: UILog: start running at thread.
       0m 43.78s: UILog: return flag at start running at thread ok.
       0m 43.79s: OPList at BD Converter : (0.2),(1.2)
       0m 43.79s: Video Converter check watermark flag: 0
       0m 44.00s: ------------------  convert work begin(1/1)  ------------------ 
       0m 44.00s: start process(1/1)
      
      ------ process working ------
       0m 00.41s: info, try to open file D:/Users/public/DVDFab/The Flash (2014) - S2E08A - Legends of Today (part 1)/The Flash (2014) - S2E08A - Legends of Today (part 1)-1_2512_2582.m4v
       0m 00.64s: info: open successed, iformat = QuickTime / MOV
       0m 00.65s: info: create config(videoconvert)
       0m 00.65s: info: crop value after clone: left = 0 right= 0 top=0 bottom=0 enable=0 mode=0
       0m 00.65s: info: use profile(MP4)
       0m 00.66s: info: file (.m4v)
       0m 00.66s: info: 3D working_mode(disable), 3D format(sbs_lef_right) 
       0m 00.66s: info: stream input@ Video(1)[codec(h264) size(1920*1080) fps(24000/1001) interlace(0) duration(69)sec opcode(compress)]
       0m 00.66s: info: perset file config OK ! 
       0m 00.67s: info: set output video frame_rate(24000/1001)
       0m 00.67s: info: recommand= 0, Shrink support= 0, enable= 0, cuda_cap= 0 , cpu_count= 8
       0m 00.67s: info: vdecode hevc= 0, h264= 0, vc1= 0, mpeg2= 0, vencode h264= 0, hevc= 0 , plat = 2 
       0m 00.68s: info: stream output Video(1)[codec(h264) size(1920*1080) fps(24000/1001) interlace(0) bitrate(19987) duration(69)sec]
       0m 00.68s: info: stream input@ Audio(2)[codec(dca) channels(6) sample(48000) bitrate(1536000) bitdepth(16) opcode(compress)]
       0m 00.69s: info: stream output Audio(2)[codec(ac3) channels(6) sample(48000) bitrate(640000) bitdepth(16) opcode(compress)]
       0m 00.69s: info: SubMode(Render) -- Display Only forced Subtitle(false) 
       0m 49.38s: UILog:MsgWork:WorkStatus_Start
       0m 00.70s: info: enable multi-thread software decoder, thread count = 8
       0m 00.70s: info: ex process path= C:/Program Files (x86)/DVDFab 10/fabcore.exe
       0m 01.88s: info: h264_encode: encode param profile(1) level(41) bitrate(19987) crf(-1) interlace(0)
       1m 46.54s: info: audio_decode finish job
       1m 46.54s: audio_encode finish job
       2m 00.40s:

      Comment


      • #4
        As you can see, I'm using a bitrate of about 20000 kbps.

        Comment


        • #5
          Seems your converting a compressed format already use a dvd or blu ray and you won't have this problem.
          info: open successed, iformat = QuickTime / MOV
          Click here to learn how to post log files

          Comment


          • #6
            The problem also affect the internal preview module.

            Anyway, I need to merge the file it's from with another. Therefore this bug is a problem for me.

            Comment


            • #7
              Reconverting the file using handbrake to h264 using baseline profile, the new file doesn't have the issue.
              Files using the High and Main profile do have the issue.

              Comment

              Working...
              X