Announcement

Collapse
No announcement yet.

10.0.4.2 Video Converter twice as slow as 10.0.3.9

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 10.0.4.2 Video Converter twice as slow as 10.0.3.9

    I convert a lot of PAL MP4 videos to NTSC so that I get smooth playback on my Roku 4 and NTSC TV.

    I had been using version 10.0.3.9 for this and like the earlier versions, I am using software decoding and encoding only because there are otherwise voice sync issues. I've seen others complain about this. I found that the software decoder and encoder worked fine and created good great quality NTSC MP4s with it set to High quality, 2-pass encoding. The encoding speed for both passes would show between 65 and 80 frames per second, usually with the higher speeds at the beginning of the encoding.

    I never installed 10.0.4.0 and went right to 10.0.4.1 from 10.0.3.9 and was disappointed to see that the software encoding was now running at HALF speed or slower! I re-installed 10.0.3.9 and got back to the original speeds. I just installed 10.0.4.2 and found that it has the same slow encoding issues that 10.0.4.1 had. Did something change to the algorithm or the x264 engine that drives the encoding? If so, PLEASE go back to the version used in 10.0.3.9 so that I can get back to acceptable encoding speeds while getting the future bug fixes.

    Has anyone else noticed this encoding slowdown?

    I'm running DVDFab on Windows 10 on an Intel Core i5 processor. Encoding a 2 hour 1280x720 MP4 from 25 fps to 29.97 fps takes about 1.5 hours total for both passes with 10.0.3.9, but closer to 4 hours with the newer versions, with NO increase in quality....

    Thanks,
    kevinfritz

  • #2
    I am not aware of any changes between those versions that would cause the symptoms you report, but there is another thread that reports a problem with 2-pass encoding. The developers will need to take a look and see if they can duplicate your problem. In the meantime, please attach a DVDFab internal log session from one of these slow conversions to a new post. Instructions for this are linked in my sig, below.

    You might also try turning off 2-pass and setting the bitrate higher using the slider until the bits per pixel (B/P) reads 0.20 or higher. Unless you have a TV with a tube-type picture display, the PAL files should display with no problem. They might look better with the frame rate set to 23.97 fps as well. Try it if you have not.
    Supplying DVDFab Logs in the Forum UPDATED..................User Manual for DVDFab v10 (pdf)..................Add a New OS Version

    Comment


    • #3
      Originally posted by signals View Post
      I am not aware of any changes between those versions that would cause the symptoms you report, but there is another thread that reports a problem with 2-pass encoding. The developers will need to take a look and see if they can duplicate your problem. In the meantime, please attach a DVDFab internal log session from one of these slow conversions to a new post. Instructions for this are linked in my sig, below.

      You might also try turning off 2-pass and setting the bitrate higher using the slider until the bits per pixel (B/P) reads 0.20 or higher. Unless you have a TV with a tube-type picture display, the PAL files should display with no problem. They might look better with the frame rate set to 23.97 fps as well. Try it if you have not.
      Another user messaged me that it could be related to the "improved conversion engine" that was previously introduced, which caused him speed problems converting 3D files. He had to go back to version 10.0.2.2 to regain the speed, and then the newer versions when he needs to rip a new disc. He noted that the improved conversion engine was supposed to speed up ripping of protected blurays, but may have introduced these issues. Not sure this would have just cropped up for me on 2D videos, but it is consistent. I'll have to re-install version 10.0.4.2 to create one of those logs....could be a few days since I need to dedicate 4 hours or so.

      PAL files create jerky movement on my NTSC Sony Bravia TV, though it is probably the Roku 4 that is playing it back that way by doing a PAL to NTSC conversion "on the fly." The Sony TV would not even play back PAL videos if PAL videos are introduced directly. Since I use my Roku 4 as my default media player, I need to convert to NTSC to get smooth playback. However, I also needed to make the conversion for my Western Digital TV media player, as PAL videos from there are jerky also. 29.97 seems to work better than 23.97 fps for both players...

      2-Pass and the high quality bit per pixel rate are the best combination of high quality and smaller files. I would hate to sacrifice size to get acceptable quality. Hopefully the issue can be found and fixed to avoid that compromise.

      Thanks for the reply.

      Comment


      • #4
        Here's a thought: could it be the following change that was introduced in 10.0.4.1 beta?

        "New: Added the 10bit support to several MKV and MP4 profiles in the Ripper and Converter modules."

        I'm not using 10-bit profiles for my MP4s, but did the base engine change to accommodate the 10-bit algorithm, and perhaps slow down the regular (8-bit?) MP4 conversion speed? Just a possibility...

        Comment


        • #5
          What are converting from and to? I'll see if I can reproduce it so far I can't.
          How to post the internal log


          Things should be made as simple as possible, but no simpler.
          Albert Einstein

          Comment


          • #6
            Originally posted by 90312 View Post
            What are converting from and to? I'll see if I can reproduce it so far I can't.
            Hi. I'm converting 1280x720 25 fps MP4 files to 1280x720 29.97 fps MP4 files. The audio is already AAC, so I set video converter to copy audio, and for video I change the fps setting and choose high quality, two-pass encoding. Codecs are set to software for both decoding and encoding. For comparison I would think any resolution should work, as long as you are changing the frames per second. Higher resolutions will obviously take longer.

            I will attempt to create a log with the old version and another with the new version, with the same settings and video input.

            Comment


            • #7
              OK, I've finally had time to do a comparison, this time with the newly release 10.0.4.3 and 10.0.3.9. I started with a fresh log file, did the conversion with 10.0.4.3 and then re-installed 10.0.3.9 and re-ran the conversion of the exact same file with the exact same options. There is still a huge difference, but this time the new version is not more than twice as slow as 10.0.3.9.

              Summary:

              10.0.3.9 = 1 hour 37 minutes conversion time

              10.0.4.3 - 2 hours 43 minutes conversion time

              Any ideas why the new versions are so much slower?

              Thanks,
              kevinfritz
              Attached Files

              Comment


              • #8
                Hi Kevin,

                I am getting normal times for the few I have made using v10.0.4.6 single pass. If you have the time, please try the same content and same settings using v10.0.4.6 and tell us your result. Sorry your are having some problem with it, that is a major slowdown. DVDFab will run faster doing any task if the reads and writes don't go to the same HDD.
                Supplying DVDFab Logs in the Forum UPDATED..................User Manual for DVDFab v10 (pdf)..................Add a New OS Version

                Comment


                • #9
                  signals:

                  Thanks for your reply. I re-ran the same input with the same options (high quality, 2-pass, software only decoding and encoding) and achieved similar slow results with version 10.0.4.6. I noticed that the file size of the 10.0.4.6 output was the same as that for 10.0.4.3 (CRC32 wasn't, but I didn't expect that), and this was about 1 MB bigger than the output created by 10.0.3.9.

                  The log for all 4 conversions is attached.

                  In summary:

                  (data from June 25th)

                  10.0.3.9 = 1 hour 37 minutes conversion time

                  10.0.4.3 - 2 hours 43 minutes conversion time

                  (data from July 10th/11th)

                  10.0.3.9 = 1 hour 35 minutes conversion time

                  10.0.4.6 - 2 hours 45 minutes conversion time


                  Could you try a 2-pass conversion also? I wouldn't expect that the ratio of times would be much different than 1-pass conversion since I can actually "see" the conversion progressing slower with the newer versions by looking at the real-time fps of the conversion process. However, other than the possible difference in our hardware, it might be helpful to eliminate one other variable.

                  So, this is a consistent difference with the new versions. It seems that something changed in versions newer than 10.0.3.9 that might only matter with my Intel Core i5 based Dell computer versus your hardware? I mentioned the possible addition of 10-bit encoding, though I'm not using that profile, but perhaps the new encoding engine that added 10-bit is not as efficient at 8-bit encoding for my processor while it doesn't matter for your processor?

                  I should also mention that I had no other processes in the foreground or background running when I performed these conversions...

                  Thanks again for your input,
                  kevinfritz
                  Attached Files

                  Comment

                  Working...
                  X