DVDFab Forum - Thor The Dark World Elvish subtitles not working

Announcement

Collapse
No announcement yet.

Thor The Dark World Elvish subtitles not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thor The Dark World Elvish subtitles not working

    I'm using DVDFab 10 and trying to rip Thor The Dark World with Elvish subtitles. I know this has been discussed before and I've tried the recommended settings of unchecking the forced subtitle setting under common settings, unchecking the forced subtitles in the 800.mpls file, and selecting the last (3rd) English checkbox while removing all others. I'm trying to rip in MP4. I've tried with and without Passthrough. I've selected multiple different alternate settings other than the selections mentioned above. I've probably tried this at least 50 diffeerent ways. It is easier on this movie because the subtitles are early in the film, so I run it to 4% and then go back and check if they are there. I can preview with viewers and sometimes they are there and sometimes they are not. After each rip I load them to my Plex server and then go and test them. If I select the subtitle listed manually within Plex, the subtitles show. I would like them directly rendered instead of having to select it. I've seen mention of selecting direct rendering through advanced settings, but when ripping the advanced settings does not show and I have no way of selecting it. I'm at my wits end. This is not the only movie that is acting this way. I am also having trouble with 3 Captain Americas (The First Avenger, Civil War and The Winter Soldier). I am assuming whatever is happening they are all related. I have also tried importing other subtitle files to try and force it to work. That doesn't work either.

    I have ripped Thor The Dark World with the recommended settings that I found. I am upload the log file to see if anyone can tell me what I am doing wrong and if there might be a suggestion that I haven't tried yet. Thanks in advance for any help you can provide.
    Attached Files

  • #2
    I am having the same problem. Tried all permutations on Thor Dark World (including just getting any subtitles) and am getting nothing.
    1. Does the play button along side the ripper entry actually show subtitles? Because this is how I start checking after several ripping attempts failed.
    2. Has anyone else ever been successful with ripping just the dark elf speech ?

    Comment


    • #3
      Hi, grumps56, your log is DVDFab 10.0.9.2 (2018/06/09 08:25:43) (X64) and it shows "SubMode(Remux) -- Display Only forced Subtitle(false)".

      Please download and install DVDFab 11.0.1.7 at http://www.dvdfab.cn/download.htm

      Then load the disc into Ripper option, choose MP4 profile, in the Audio column, select the subtitle track which contains "forced subtitle" and choose "Display only forced subtitle", then click on the wrench button to open "Advanced Settings" window, in Subtitle part, go to Mode, choose "Direct Render to video" to convert.

      Still fails, please send us the latest dvdfab_internal log, thanks.

      User Manual for DVDFab v10 (pdf)

      DVDFab log default location:
      For Windows: C:\Users\User Name\Documents\DVDFab10\Log
      For Mac: Finder> Documents> DVDFab10> Log

      DVDFab Player 5:
      For Windows:C:\Users\User Name\Documents\DVDFab Player 5\Log

      Comment

      Working...
      X