DVDFab Forum - 1st impression, small bugs and some suggestions

Announcement

Collapse
No announcement yet.

1st impression, small bugs and some suggestions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1st impression, small bugs and some suggestions

    hi

    just tested dvd fab media player 5 ( 5.0.0.6)
    compared to 3.x its a nice udpate

    - dvd playback is now silent during playback (drive spins up and after 1 sec it goes to silent mode like with vlc or mpc be/hc)
    - cpu usage with 4k hevc videos is now much lower


    but i found also some small bugs/problems

    - audio volume setting is not saved when exiting dvd fab media player
    - audio volume is not set to maximum per default after opening dvd fab (seems to be set to 90%)


    some old bugs which were present in 3.x and are still in 5.x

    - very long loading time (about 1 min) when open a video from a folder which conatins several hundred files.
    when u open a file from a folder which has only a few files playback starts immediately.

    i guess i found the reason for this:
    dvd fab media player scans the entire folder before starting to play a video !!
    this is very annoying and completely unnecessary (all other players like mpc hc/be, vlc etc will start playback immediately no matter how many files are in the folder)

    after dvd fab media player has scanned the folder it will open every video of the folder immediately
    but if you reboot and start windows again, dvd fab media player will scan the folder again before playing a video.

    hope this scanning of the folder will be disabled in the future


    - dvd fab media player still creates a log file (with every video dvd fab played it becomes larger)
    and for some videos it will create some temp files no other player is doing this !
    would be good if logging could be disabled completely in options !

    - when a folder contains a ripped dvd (video_ts folder) dvd fab media player will start to play the dvd immediatley when you try to open the folder
    you have no chance to select a vob or ts file manually
    (so far this has not been a problem but still a strange behaviour)

    - i found a file .avi with build in sub titles and dvd fab media player cannot read the sub title
    (vlc and mpc hc cannot either only mpc be can)

    - dvd fab media player offers no asio/wasapi audio support for videos like mpc hc / be
    would be nice to add this to play video files with 1:1 audio format for eg. with a usb dac.

    hope these old dvd fab bugs with long loading times with large folders with 1st video and the logging behaviour will be changed in the future
    Last edited by otto4711; 02-07-2018, 11:21 PM.

  • #2
    Hi otto4711,

    Thank you very much for the feedback and suggestions, we will consider them ASAP.

    Best Regards,
    Fengtao
    DVDFab is the all-in-one software package for copying Blu-ray/DVD and converting video file.
    http://www.dvdfab.cn

    Comment


    • #3
      Hi,

      Thanks for choosing DVDFab Player and the good feedback.

      - audio volume setting is not saved when exiting dvd fab media player
      - audio volume is not set to maximum per default after opening dvd fab (seems to be set to 90%)
      The problem that the audio volume could not be saved will be fixed in next version.
      The problem that the audio volume is smaller than others, it will be fixed in next version.

      some old bugs which were present in 3.x and are still in 5.x

      - very long loading time (about 1 min) when open a video from a folder which conatins several hundred files.
      when u open a file from a folder which has only a few files playback starts immediately.

      i guess i found the reason for this:
      dvd fab media player scans the entire folder before starting to play a video !!
      this is very annoying and completely unnecessary (all other players like mpc hc/be, vlc etc will start playback immediately no matter how many files are in the folder)

      after dvd fab media player has scanned the folder it will open every video of the folder immediately
      but if you reboot and start windows again, dvd fab media player will scan the folder again before playing a video.

      hope this scanning of the folder will be disabled in the future
      It will be improved in the future version.

      - dvd fab media player still creates a log file (with every video dvd fab played it becomes larger)
      and for some videos it will create some temp files no other player is doing this !
      would be good if logging could be disabled completely in options !
      The log files are usefull for us to check the user reported problem. We will consider this to add a option (enable and disable log output) in the future version.

      - when a folder contains a ripped dvd (video_ts folder) dvd fab media player will start to play the dvd immediatley when you try to open the folder
      you have no chance to select a vob or ts file manually
      (so far this has not been a problem but still a strange behaviour)
      yeah, we added this in player 5, it's better to playback the folder if it's the DVD/Blu-ray folder.

      - i found a file .avi with build in sub titles and dvd fab media player cannot read the sub title
      (vlc and mpc hc cannot either only mpc be can)
      Please post the mediainfo of the .avi file, you can get it by the free tool Mediainfo. https://mediaarea.net/en/MediaInfo/Download/Windows

      - dvd fab media player offers no asio/wasapi audio support for videos like mpc hc / be
      would be nice to add this to play video files with 1:1 audio format for eg. with a usb dac.
      DVDFab Player 5 supports to playback with the device wasapi, play5 will detect automatically when output with Analog or HDMI.
      Asio and USB DAC, it will be supported in the future version.

      Thanks!

      Wilson
      Please post your logs the default location is:
      For DVDFab9_Win7 & Win8 C:\Users\User Name\My Documents\DVDFab9\Log
      For DVDFab10_Win7 & Win8 C:\Users\User Name\My Documents\DVDFab10\Log
      For Mac: /User/User name/Documents/DVDFab10/Log
      Please use attachment button and attach your most recent, Internal log and post right here.
      If it's the burning issue, please also attach burn log.

      Thanks!

      Comment


      • #4
        thx for the good news :-)

        i know that log files can be important if there is a problem
        but an option to turn it off would be nice.


        here the mediainfo of the avi file

        General
        Complete name : D:\Buddy haut den Lukas - Langfassung DVDRip AC3.avi
        Format : DivX
        Format/Info : Hack of AVI
        Format profile : OpenDML
        File size : 1.51 GiB
        Duration : 1 h 38 min
        Overall bit rate : 2 204 kb/s
        Writing application : Lavf55.23.103
        FileExtension_Invalid : divx

        Video
        ID : 0
        Format : MPEG-4 Visual
        Format profile : Simple@L3
        Format settings, BVOP : No
        Format settings, QPel : No
        Format settings, GMC : No warppoints
        Format settings, Matrix : Default (H.263)
        Codec ID : XVID
        Codec ID/Hint : XviD
        Duration : 1 h 38 min
        Bit rate : 1 999 kb/s
        Width : 720 pixels
        Height : 404 pixels
        Display aspect ratio : 16:9
        Original display aspect ratio : 16:9
        Frame rate : 25.000 FPS
        Color space : YUV
        Chroma subsampling : 4:2:0
        Bit depth : 8 bits
        Scan type : Progressive
        Compression mode : Lossy
        Bits/(Pixel*Frame) : 0.275
        Stream size : 1.37 GiB (91%)
        Writing library : XviD 64

        Audio
        ID : 1
        Format : AC-3
        Format/Info : Audio Coding 3
        Format settings, Endianness : Big
        Codec ID : 2000
        Duration : 1 h 38 min
        Bit rate mode : Constant
        Bit rate : 192 kb/s
        Channel(s) : 2 channels
        Channel positions : Front: L R
        Sampling rate : 48.0 kHz
        Frame rate : 31.250 FPS (1536 SPF)
        Bit depth : 16 bits
        Compression mode : Lossy
        Stream size : 135 MiB (9%)
        Alignment : Aligned on interleaves
        Interleave, duration : 32 ms (0.80 video frame)
        Title : Stereo
        Service kind : Complete Main

        Text
        ID : 2
        Format : DivX Subtitle
        Codec ID : DXSB
        Codec ID/Info : Subtitle in AVI from DivX networks
        Width : 720 characters
        Height : 576 characters
        Bit depth : 4 bits
        Stream size : 270 KiB (0%)
        Title : Subtitle - de-xx;02


        dvd fab media player detects the subtitles but plays them all during the 1st few seconds of the movie with fast speed.
        the movie is in german with some parts in italien and these italien parts during the movie should have subtitles when enabled.




        i found another small problem with some of my older self burned dvds.
        7 or 8 years ago i converted some dvd 9 to dvd 5 with tmpgenc.
        when i want to open them dvd fab media player tries to read them and says its loading and the drive reads the dvd
        but the player got stuck and is trying to open the dvd infinitely.
        (using simple or menu mode in options makes no difference)

        when i open these dvds over the "media open" option dvd fab will play them with menu and everything
        but with this way the drive speeds up to maximum and stays that way for the whole movie.
        making so much noise that its not watchable.
        because the drive does not slow down in normal file reading mode like in dvd disc mode.

        these dvds have normal video_ts folder so i don't know why the player has problems reading them in disc mode
        but can open them with media open mode.
        may be the player cannot find the css key (these dvds have none) or has trouble finding the video_ts.ifo file.

        happens only with tmpgenc converted dvds
        other self burned dvds work without problem.

        mpc hc/be can open them without a problem
        and plays them silent in disc mode.




        and here i have another small suggestion for dvd fab media player :-)

        -when you play a video in a window the border of dvd fab media player with the seekbar and title on top of the video window will disappear after 3 seconds of playback.
        it would be nice to have an option to keep the dvd fab media player border in window mode.

        why ? well depening of the background colour it looks better with a frame around the window.




        and for dvd fab media player 6.x
        i have some ideas :-)

        how about adding audio cd support and idtag showing during playback of mp3, flac, ape and other audio files and cue file support for audio files.
        to make dvd fab media player not only a good video player but also a good audio player :-)


        thx
        otto
        Last edited by otto4711; 02-08-2018, 07:16 AM.

        Comment


        • #5


          avi....
          dvd fab media player detects the subtitles but plays them all during the 1st few seconds of the movie with fast speed.
          the movie is in german with some parts in italien and these italien parts during the movie should have subtitles when enabled.
          --About AVI subtitle problem, please send us the problematic source. Thank you.

          happens only with tmpgenc converted dvds
          other self burned dvds work without problem.

          mpc hc/be can open them without a problem
          and plays them silent in disc mode.
          --We don't have this kind of tmpgenc converted dvds for testing now.

          Please try to open the disc again and then post the latest Player 5 log file.

          --The two suggestions have been forwarded to the product manager.

          Regards,
          mona
          DVDFab log default location:
          For Windows: C:\Users\User Name\Documents\DVDFab11\Log
          For Mac: Finder>Documents>DVDFab11>Log

          DVDFab Player 5:
          For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
          For Mac: Finder>Documents>DVDFab Player 5>Log

          Guide for adding attachments in a post
          --Please use attachment button to attach your most recent log files.

          Comment


          • #6
            hi
            thx for the support

            here is the log file when i try to open the dvd
            after 2 min i removed the dvd from the drive and a few seconds later dvd fab media player returns to normal opening screen.
            http://www2.zippyshare.com/v/KJELaQbk/file.html


            here is the
            avi file with the subtitle problem
            http://www53.zippyshare.com/v/MRN91z1F/file.html
            http://www53.zippyshare.com/v/8QJofBWc/file.html
            http://www53.zippyshare.com/v/6ksQviit/file.html
            http://www53.zippyshare.com/v/1kymx0Lf/file.html


            i found another file which is makling some trouble
            this is a imax 4k hevc file
            http://www74.zippyshare.com/v/7n9x0SdW/file.html

            when i open it with dvd fab media player it says that hardware decoding for 4k h.265 video is not supported on my hardware.
            ( i use w10 and a nvidia gtx 960 with latest driver)
            video is then played without hardware acceleration with stutters
            other 4k h.265 videos work without problem with dvd fab media player
            the file works with hw acceleration with mpc hc/be.

            Comment


            • #7
              hi thx for the support
              seems my posting got deletet when i include links
              hope it will work this time.


              here the log files
              after 2 min i removed the dvd from the drive
              dvd fab media player goes then back to normal opening screen
              h**p://www84.zippyshare.com/v/BQL82T1Q/file.html

              here the avi file with subtitle problem
              h**p://www53.zippyshare.com/v/MRN91z1F/file.html
              h**p://www53.zippyshare.com/v/8QJofBWc/file.html
              h**p://www53.zippyshare.com/v/6ksQviit/file.html
              h**p://www53.zippyshare.com/v/1kymx0Lf/file.html

              i found another video which is making some trouble
              this is a imax 4k h.265 video
              h**p://www74.zippyshare.com/v/7n9x0SdW/file.html
              dvd fab media player says that hardware decoding is not supported for h.265 4k videos on my system.
              ( i use w10 and a gtx960 with latest driver)
              the file is then played without hardware acceleration with stutters.
              other 4k hevc videos play without problem.



              Comment


              • #8
                its me again :

                i just noticed that when dvd fab media player runing in window and is showing the title on top and seekbar on bottom for the first 3 seconds of playback,
                the border cover up some of the video screen on top and bottom.

                should you realize my suggestion of keeping the borders around the video screen in window mode (may be activate and deactivate in options)
                you have to move the dvd fab titel and seekbar frame out of the video window and attach it outside the video window !
                otherwise it will cover up some of the video on top and bottom during the entire video.
                Last edited by otto4711; 02-10-2018, 01:32 AM.

                Comment


                • #9
                  i uploaded the videos to the ftp
                  "subtitle not working.avi" and "hardware decoding not working.mkv"

                  Comment


                  • #10
                    Hi,

                    Thank you for the feedback.

                    We've downloaded the .avi file and the .mkv file, we will need some time to check out this subtitle playback and hardware decoding problem.

                    About the suggestion of keeping the borders but not covering top and bottom movie, I will pass it to our product manager for checking first. Whether this feature will be added in the future or not is unsure yet. Thank you for your understanding in advance.

                    Regards,
                    mona
                    DVDFab log default location:
                    For Windows: C:\Users\User Name\Documents\DVDFab11\Log
                    For Mac: Finder>Documents>DVDFab11>Log

                    DVDFab Player 5:
                    For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
                    For Mac: Finder>Documents>DVDFab Player 5>Log

                    Guide for adding attachments in a post
                    --Please use attachment button to attach your most recent log files.

                    Comment


                    • #11
                      Hi,

                      We have got the result from the QA Team test, it turns out that the subtitle file for the video is problematic. It does not have a timestampe. Also, as you mentioned above, the subtitle cannot be played by VLC either. Thus it is a subtitle issue, not a DVDFab Player 5 problem

                      Thanks.

                      Regards,
                      Ashley
                      User Manual for DVDFab v10 (pdf)

                      DVDFab log default location:
                      For Windows: C:\Users\User Name\Documents\DVDFab10\Log
                      For Mac: Finder> Documents> DVDFab10> Log

                      DVDFab Player 5:
                      For Windows:C:\Users\User Name\Documents\DVDFab Player 5\Log

                      Comment


                      • #12
                        thx for the answer


                        media player classic black edition (mpc be) can play it
                        but its not a big problem.

                        Comment

                        Working...
                        X