DVDFab Forum - DVDFab x64 crashes when SRT subtitles are selected

Announcement

Collapse
No announcement yet.

DVDFab x64 crashes when SRT subtitles are selected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blu-ray DVDFab x64 crashes when SRT subtitles are selected

    Hi,
    I am using DVDFab x64 11.0.8.8 on Windows 10.
    I'm trying to use ripper with the subtitle option set to SRT, but it crashes soon after commencing the process (within a few seconds). If I select the remux option instead it works fine.
    Any idea what is happening?

    Thanks,
    Alan.

    #2
    Log files attached
    Attached Files

    Comment


      #3
      Thank you for your report, we will try to reproduce the issue first. I will keep you updated.
      DVDFab log default location:
      For Windows: C:\Users\User Name\Documents\DVDFab11\Log
      For Mac: Finder>Documents>DVDFab11>Log

      DVDFab Player 5:
      For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
      For Mac: Finder>Documents>DVDFab Player 5>Log

      Guide for adding attachments in a post
      --Please use attachment button to attach your most recent log files.

      Comment


        #4
        Please note - it also crashes when selecting subtitle mode = Remux, and sub-mode SRT Subtitle.
        Remux mode with PGS Subtitle works fine.

        Comment


          #5
          Originally posted by avw611 View Post
          Please note - it also crashes when selecting subtitle mode = Remux, and sub-mode SRT Subtitle.
          Remux mode with PGS Subtitle works fine.
          We tried several different sources but we cannot reproduce the crash issue. Is this problem only with some specific source? We will need a movie iso file to help duplicate it.
          If this is a common issue, please try completely remove DVDFab and then reinstall it to try again.
          DVDFab log default location:
          For Windows: C:\Users\User Name\Documents\DVDFab11\Log
          For Mac: Finder>Documents>DVDFab11>Log

          DVDFab Player 5:
          For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
          For Mac: Finder>Documents>DVDFab Player 5>Log

          Guide for adding attachments in a post
          --Please use attachment button to attach your most recent log files.

          Comment


            #6
            I've uninstalled and reinstalled DVDFab, tried again, it still crashes.
            I tried several different ISO files from blu-ray source, and several ISO files from DVDs, the same behaviour is happening in all of them.
            It crashes when it starts creating the video file: if I use 1-pass encoding, it crashes within a few seconds. If I use 2-pass encoding, it gets to 50% and then crashes. The video file is not created, but an SRT file is created, although it's an empty file.

            If the video title being ripped has no selected subtitles, the process completes successfully, although obviously no subtitles are generated.
            DVDFab-Logs_20200520.zip
            I'm attaching some logs here again.

            Comment


              #7
              Okay, we will try again.

              UPDATE:Still cannot reproduce, Extract to SRT file and Remux into file (SRT Subtitle), both worked well.
              Please try again, but do not use the profile(MKV.Default), use the one comes with DVDFab to see the result.
              DVDFab log default location:
              For Windows: C:\Users\User Name\Documents\DVDFab11\Log
              For Mac: Finder>Documents>DVDFab11>Log

              DVDFab Player 5:
              For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
              For Mac: Finder>Documents>DVDFab Player 5>Log

              Guide for adding attachments in a post
              --Please use attachment button to attach your most recent log files.

              Comment


                #8
                No luck.
                Here is what I tried:
                1. Downloaded the latest version (11.0.8.9)
                2. Imported my ISO file
                3. Selected The Mobile (Mp4) profile
                4. Entered setup and changed subtitles to "extract to srt file"
                5. Started the process, crashed within 5-10 seconds
                6. Tried the same with the default MKV file, only changing the subtitles to SRT.
                7. Started the process. Since the default MKV is 2-pass, it progressed to 50% and crashed within 5-10 seconds of starting the second pass

                I then tried:
                1. Uninstall DVDFab 11
                2. Uninstall DVDFab 10 (which I also had on my system)
                3. Remove the folders left behind under C:\Program Files (DVDFav 10 and DVDFAB 11)
                4. Remove the log folders under Documents (including DVDFabCommon)
                5. Reinstalled DVDFab 11.0.8.9
                6. Tried the ripping steps above again using the default MKV profile
                7. DVDFab crashes as before

                I then disabled my anti virus and tried the above again. It still crashes in the same way.

                I'm at a loss as to what else I can try to get this working.

                The only other DVDFab software I have installed is Media Player 3

                Comment


                  #9
                  Hello,
                  Just revisiting this issue. Are there any developments?

                  Comment


                    #10
                    Originally posted by avw611 View Post
                    Hello,
                    Just revisiting this issue. Are there any developments?
                    We've tried different sources on different computers, we are unable to reproduce your case. The developer is trying to diagnose the issue via log files, once I get an update from them, I will let you know.
                    DVDFab log default location:
                    For Windows: C:\Users\User Name\Documents\DVDFab11\Log
                    For Mac: Finder>Documents>DVDFab11>Log

                    DVDFab Player 5:
                    For Windows: C:\Users\User Name\Documents\DVDFab Player 5\Log
                    For Mac: Finder>Documents>DVDFab Player 5>Log

                    Guide for adding attachments in a post
                    --Please use attachment button to attach your most recent log files.

                    Comment


                      #11
                      Originally posted by avw611 View Post
                      Hello,
                      Just revisiting this issue. Are there any developments?
                      do you still get the crash if you select
                      common settings - AV Codec - switch everything to software - restart dvdfab
                      and retry your SRT subtitles again.

                      Comment


                        #12
                        Originally posted by october262 View Post

                        do you still get the crash if you select
                        common settings - AV Codec - switch everything to software - restart dvdfab
                        and retry your SRT subtitles again.
                        On my AV Codec tab everything is already set to Software.
                        I tried turning off the Lightning-Recording option (which was turned on before), however it is still crashing.
                        Latest logs attached.
                        Attached Files

                        Comment

                        Working...
                        X