DVDFab Forum - DVDFAB Update

Announcement

Collapse
No announcement yet.

DVDFAB Update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Software DVDFAB Update

    I haven't used this for some time, after starting today I got the message that there was an update.
    Allowed the update to download and install, restart laptop, now when starting DVDFab I get the following;

    The current of version of DVDFab is unknown, please update to the latest version.

    Ok, so I downloaded the latest version from the website, ran the installer, restart laptop....same error, so I tried run as administrator...same error.

    Running Windows 10 1607, not too sure when to start to resolve.

    Apologies if this in the wrong place.

  • #2
    Try doing a clean Uninstall of dvdfab Run a good
    registry cleaner and reinstall dvdfab " as administrator "

    Comment


    • #3
      Originally posted by october262 View Post
      Try doing a clean Uninstall of dvdfab Run a good
      registry cleaner and reinstall dvdfab " as administrator "
      Ok removed both versions, ran ccleaner, then did a registry search and deleted everything it pick up using dvdfab as the search option.

      However, still the same, it starts comes up with the firewall allow access left it at private but have since changed it to public as well.....still the same error.

      Splash screen comes.....accessing server...then the error....so there is a config issue somewhere.

      Comment


      • #4
        What antivirus software do you have ??

        Comment


        • #5
          Originally posted by october262 View Post
          What antivirus software do you have ??
          It's not antivirus

          Checked the event log:

          The certificate received from the remote server does not contain the expected name. It is therefore not possible to determine whether we are connecting to the correct server. The server name we were expecting is www.dvdfabstore.com. The TLS connection request has failed. The attached data contains the server certificate.

          So the issue is related to a config setting somewhere...Oh I also checked my member login and that works

          Comment


          • #6
            This is definitely some sort of tls/authentication problem, as the splash screen starts, you the see Accessing Server Information as which point it bombs.
            I do know you can set up or it may do it automatically an alias for certificate authentication.

            Comment


            • #7
              Well having tried 10 so many times this will still not get past Accessing Server Information on the splash screen.
              So I decided to try v9....same error as v10 so I have an issue with something, I've attached the dvdfab_internal log for v9 as it's an identical output to v10.
              There is definitely something wrong regarding ssl, but this one is beyond my remit.
              Attached Files

              Comment


              • #8
                Does your Internet provider use some sort of Internet Protection program ??

                Comment


                • #9
                  No, same provider I was using when I was on W7 and v9......

                  I have spare HDD, I just might install W7, update then try v9

                  The failure is related to the 2 lines in the log error curl post: SSL connect error

                  Comment


                  • #10
                    I think we're getting somewhere...
                    http://www.dvdfabstore.com returns IS OK! in a browser...however,
                    https://www.dvdfabstore.com returns a certificate error

                    But!! https://dvdfabstore.com returns IS OK! this is dns/ip mapping I think

                    I think Fab is looking for https:// when attempting 'Accessing server information' but the certificate wants http://

                    So either a redirect is required within Fab or a redirect/alias on the certificate.

                    This is a similar problem I encountered when setting up remote access for school using ssl certification, a redirect was put in place on IIS to resolve connection/authentication.
                    Last edited by geaves; 12-22-2016, 07:58 AM.

                    Comment


                    • #11
                      Well I thought I would keep updating, I decided to re image my laptop back to 19/12, no V10 installed, just 9.2.3.1, this actually works and even asks for my new server login.

                      However, the internal log for v9 generates this error;
                      error curl post: Peer certificate cannot be authenticated with known CA certificates
                      which is interesting as whilst it detects there is an error with the site certificate it still loads.
                      Install v10 same error as before, so there is some sort of issue with the site certification.

                      Comment


                      • #12
                        Are you using a VPN or a proxy connection ??

                        Comment


                        • #13
                          No, all my browsing, email is done on my Linux machine.

                          That error in bold relates to the cached certificate on my laptop, so what that tells me is that the certificate on the site cannot be authenticated with the locally cached one. But with v9 it's using the locally cached certificate to allow the connection. v10 on the other hand needs to authenticate and download a certificate to use, hence it's failure, because it's looking for https://www.dvdfabstore.com whereas the certificate is authenticating https://dvdfabstore.com

                          Simples

                          The thing is I'm not sure if there is a reference to the certificate in the registry under v9, if there is, one could copy that key to the v10 registry settings.

                          Comment


                          • #14
                            Another update, totally clean install of windows 10 on another drive (the other is an upgrade from windows 7)
                            V10 works!! even with anti virus running...so something is preventing/or throwing the error on my upgraded version. I'll have to put the other HD back as my laptop is for remote work use, but it has the advantage that we have M/S volume licencing which helps with clean installs and testing.

                            I am now seriously contemplating testing this on Linux under wine because there are times when M/S becomes so frustrating that the light at the end of the tunnel gets dimmer and dimmer.
                            I have opened a support ticket and sent requested information, two days in a row I received emails and replied.....today nothing so I'm wondering if it's got them stumped as well, cos I am.

                            Comment


                            • #15
                              See here - http://forum.dvdfab.cn/showthread.php?t=27511

                              Comment

                              Working...
                              X