DVDFab Forum - Ripping issues with Forced Subtitles & Plex

Announcement

Collapse
No announcement yet.

Ripping issues with Forced Subtitles & Plex

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BD Ripper (3D Plus) Ripping issues with Forced Subtitles & Plex

    I am having issue while ripping Blu Ray movies with Forced Subtitles.

    As an example, I am currently working with The Godfather Part II

    My setup is that I use Plex as my media server running through a Roku or on my Apple devices (iPhone and iPad).

    What I would like to have is a file with the best quality video and audio, Forced Subtitles on by default, and also have the ability to turn on English subtitles in case the audio is not clear and I'm trying to win or lose a drunken argument about what was just said.

    The format I've been using is MP4 but I could be talked into MKV if it would resolve my issue.

    What happens is I rip the video, selecting all the English subtitles and setting the Display Only Forced on the subtitles. The resulting rip contains all the subtitle tracks as selectible, but the Forced track is not on by default when I play it through Plex.

    I've seen reference in other posts to setting this manually using something called Subtitle Edit. I downloaded this last night, but could not see a way to set a "forced flag" for a subtitle track.

    Can anyone tell me what I'm doing wrong here? I just want to rip the movies so they play like the disk does on my Blu Ray player, with the option to turn on full English subtitles manually if I want.

  • #2
    Do you have Plex setup correctly?
    https://support.plex.tv/articles/200...title-support/
    https://support.plex.tv/articles/204...uage-settings/

    I burn-in all Forced Subtitles so that the video is Direct Played.
    I don't rip any subtitles as a separate SRT file.
    So I can never turn on subtitles during playback.
    To do what you want, I think you would have to rip the movie with the forced subs burned-in and then rip the subtitles separate and add them to the movie folder.

    Comment


    • #3
      I believe I have PLEX setup to play the forced subtitle track when it's there. I have other movies where it seems to play the forced subs, but I recognize it's possible those could be burned into the image.

      I think the actual issue is that the subtitle track is not flagged correctly. I just don't know how to change that. Again, I used Subtitle Edit but could not see anything that seemed to allow me to set the subtitle flag.

      Comment


      • #4
        I have this issue as well. Usually it is the second Subtitle Track for me, but PLEX doesn't play it automatically, and neither does Windows 10 Movies and TV app...

        Comment


        • #5
          You can set the forced flack in MKVtoolnix (assuming that you are ripping to MKV)...
          • open the file in their GUI (header editor).
          • Pick the subtitle track to be forced
          • Select the track‘s forced property and set it to true/yes
          • Save the file

          Comment


          • #6
            Originally posted by Nik_Simpson View Post
            You can set the forced flack in MKVtoolnix (assuming that you are ripping to MKV)...
            • open the file in their GUI (header editor).
            • Pick the subtitle track to be forced
            • Select the track‘s forced property and set it to true/yes
            • Save the file
            I am ripping to MP4 in almost all instances. I still want to stay compatible with my Apple devices (iPhone and iPad).

            Comment

            Working...
            X